Процедура Writeln в Pascal

Помимо зарезервированного слова Write, для вывода сообщения на экран в Pascal используется процедура Writeln. Отличие процедуры Writeln от оператора Write заключается в том, что Writeln после вывода сообщения на экран переводит курсор на другую ...

Операции умножения и сложения в Pascal.

В данном уроке мы рассмотрим операции умножения и сложения в Pascal. Умножение в Pascal обозначается знаком «*», а сложение - знаком «+».

Div, Mod, сложение, вычитание в Pascal.

Помимо операций умножения и сложения, над целочисленными переменными производятся операции Div (операция целочисленного деления), Mod (вычисление остатка от целочисленного деления), операция вычитания «-».

Циклы и массивы

Многомерные массивы.

Индексы имеют еще одно свойство — чем больше объем массива, тем менее эффективна с ним работа, поэтому часто используют массивы массивов, то есть с двумя, тремя и более индексами для идентификации ...

Индексы одномерного массива.

Существует класс задач, в которых индекс массива используется для формализации вычислительного процесса путем сведения исходных формул к конечным суммам и произведениям. Преобразованные таким образом ...

Напишем программу, которая вычисляет сумму положительных элементов в массиве.

 Вычисление суммы положительных элементов массива.




program massiv6;
uses crt;
const N=10;
type x=array [1..N] of integer;
var a:x;
i:integer;
s:integer;
begin
clrscr;
randomize;
for i:=1 to N do
begin
a[i]:= -100+random(201);
write (A[i]:5)
end;
writeln;
s:=0;
for i:=1 to N do
if a[i]>0 then
begin
s:=s+a[i]
end;
writeln (‘Сумма положительных элементов =  ’,s:5);
readln
end.



В строке №7 переменная «S» – для хранения суммы.

В строке №13 генерируем 10 различных чисел в диапазоне от – 100 до + 100.

В строке №14 выводим эти числа на экран.

В строке №17 обнуляем переменную «S»

В строке 19 задаем условие: если значение элемента массива (т.е. если сгенерированное число) больше 0, тогда в строке №21 прибавляем к сумме это число. Таким образом, после выполнения цикла, все положительные числа должны прибавиться к общей сумме.

summa polozhiteljnihkh ehlementov massiva

summa polozhiteljnihkh ehlementov massiva.


Предыдущая статья : Нахождение максимального элемента массива.

Оглавление : Уроки Паскаль.

Следующая статья : Подсчет количества четных элементов в массиве.


Комментарии  

 
+3 # like 12.02.2013 10:29
:cry:
 
 
+3 # like 12.02.2013 10:29
спосибо :lol:
 
 
+4 # Анна 04.03.2013 17:47
Написать текс программы для следующих задач: 1. Сформировать массив М(15) ДСЧ (-10, 15). Ввести и вывести элементы массива в столбик. Для элементов массива, кратных 3 найти сумму квадратов, для отрицательных элементов найти половину произведения. 2. Сформировать массив А(4,5) из блока данных. Для элементов массива с нечетным номером строк найти среднее арифметическое, для положительных элементов найти удвоенную сумму.,
 
 
+2 # анхеликобр письказав 23.12.2014 11:44
8)
 
 
0 # Катюша 24.01.2015 07:07
Спасиибо!) :lol:
 
 
0 # нефтяник 18.04.2015 06:29
;-) спасибо
 
 
0 # Макс 28.09.2015 18:39
спасибо вы очень помогли
:D :D :D :lol: :lol: :lol:
 
 
0 # Вам 07.03.2016 11:43
:-)
 
 
0 # не щз 13.06.2016 14:00
:lol: :lol: :lol: :lol: :lol:
 
 
0 # не щз 13.06.2016 14:01
:-) :-) ;-)
 
 
0 # сука 13.06.2016 14:02
:oops: :oops: :oops: :oops: :oops: :oops: :oops: :oops: :oops: :oops: :oops: :oops: :oops: :oops: :oops: :oops: :oops: :oops: :zzz :zzz :zzz :zzz :zzz
 
 
0 # мария 20.03.2017 06:54
напишите программу вычисляющую среднее арифметическое по массиву целых чисел до (50)
если это срееднее арифметическое ≥ 4.5 , выдать сообщения "Пять за четверть ".
 
   ГлавнаяПаскальМассивы в ПаскальВычисление суммы положительных элементов массива.