Строки в Паскаль.

Тип данных String (строковый тип) используется в Паскаль для обработки текстов. Если в одну переменную типа Char можно записать лишь один символ, то в переменную типа String можно записать до 255 символов.

Строковые константы в Pascal.

В качестве значения строковой константы может выступать любая последовательность символов. Эта последовательность заключается в апострофы. Строковая константа отличается от символьной константы тем, что здесь в качестве значения константы можно ...

Операции умножения и сложения в Pascal.

В данном уроке мы рассмотрим операции умножения и сложения в Pascal. Умножение в Pascal обозначается знаком «*», а сложение - знаком «+».

Циклы и массивы

Примеры линейных программ.

В данной статье приводится несколько примеров линейных программ на языке программирования Паскаль.

Оператор варианта CASE.

Иногда его называют также оператором выбора. Это оператор CASE, который является обобщением оператора IF и позволяет сделать выбор из произвольного числа имеющихся вариантов.

Уроки Паскаль

Помимо зарезервированного слова Write, для вывода сообщения на экран в Pascal используется процедура Writeln. Отличие процедуры Writeln от оператора Write заключается в том, что Writeln после вывода сообщения на экран переводит курсор на другую строку.

Program number2;
uses crt;
begin
clrscr;
write ('Привет. ');
write (‘Как дела?’);
readln
end.

В строке №5 и №6 мы выводим на экран два сообщения. Для того чтобы отделить сообщения друг от друга, ставим пробел после слова «Привет» перед закрывающим апострофом.

Записываем программу в Паскале и нажимаем F2 для сохранения.

procedura Writeln v paskalj

После запуска программы Ctrl+F9 на экран выводится следующее сообщение.

procedura Writeln v paskalj.

Как мы видим, на экран вывелось два сообщения: «Привет.» и «Как дела?». Оба этих сообщения вывелись в одной строке. Для того чтобы сообщения выводились на разных строках, вместо оператора Write нам нужно использовать оператор Writeln (от англ. Write Line - записать строку).

Program number2;
uses crt;
begin
clrscr;
writeln ('Привет. ');
write (‘Как дела?’);
readln
end.

В строке №5 мы записываем оператор Writeln. Помимо того, что он выводит на экран сообщение, он еще переводит курсор на следующую строку. Поэтому следующее сообщение выводится во второй строке. Фактически оператор Writeln выполняет процедуру Write, а затем переводит курсор на следующую строку.

procedura Writeln v paskalj...



Дополнение к материалу.

Следует сказать, что оператор «writeln» не является зарезервированным словом в Pascal. Если посмотреть на код, набранный в Pascal, то мы увидим, что оператор «writeln» не выделен белым цветом (как все зарезервированные слова). Он выделен желтым цветом, поскольку является идентификатором. Однако, в отличие от пользовательских идентификаторов, которые программист придумывает сам (например, название программы), оператор «writeln» является стандартным идентификатором. Стандартные идентификаторы связаны с предварительно объявленными объектами и входят в стандартную библиотеку Турбо Паскаля.

Комментарии  

 
+1 # Семён 27.11.2012 18:35
:lol: ура я юный 13-летний программист пока справляюсь
 
 
+15 # Нео 08.12.2012 10:24
ты юный ученик, а юный программист это тот кто уже знает хотя бы 1 язык программировани я. :roll:
я в свои 15 изучал Visual Basic и HTML, делал игры в Scirra Construct, но пока я себя програмистом не считаю
 
 
-11 # Алеша 20.10.2017 17:41
А мне тоже 13 лет но я уже виучил HTML5 CSS3 JavaScript jQuery учу C# PHP FreePascal хотя FreePascal я даже не думал учить учу на Олимпиаду :lol:
 
 
+16 # Ольга 29.11.2012 16:48
:cry: А мне 37 и у меня не получается.
 
 
-2 # seva 30.11.2012 15:14
:P
 
 
-6 # seva 30.11.2012 15:22
:-x
 
 
+5 # Максалина 10.12.2012 18:40
Помогите составить программу Z=(X в кубе/9+yx в квадрате)*99/y+ x при х=2 y=3
 
 
+5 # Максалина 18.12.2012 10:04
Извините. Составлять программу уже не надо. У меня уже всё получилось.
 
 
-6 # Тимур 30.01.2013 16:30
я прочел 2 урока. учительница будет рада
 
 
-3 # тамирис 11.02.2013 12:42
:cry: помогите мне сказали сделать рисунок! я на этои теме не была ((((
 
 
-2 # информ тупость! 11.02.2013 12:59
тамирис у меня тоже самое и вот я ваще не знаю у нас затро этот урок та же самая история а оа у нас пофигистка ей пофиг была ты не была :eek:
 
 
-2 # Александр 16.03.2013 16:21
А мне 16, я знаю язык HTML... И что бы изучить другие более сложные языки, я начал изучать основы основ программировани я PASCAL))) 8)
 
 
+1 # Виталя 21.05.2013 16:50
А йа поставил точку после енд....
мне паставили пьать
 
 
-6 # Сергей 25.11.2014 11:44
А у меня заработало всё только с концовкой
readln
end;
end.
:-)
 
 
-6 # Юи 05.02.2015 18:37
Мне надо сдавать информатик . Но я пропустила из- за болезни тему программировани е успела только к середине сейчас ничего не понима . Писец полны . Увожаемые ученики и юные программисты не пропускайте и минуты когда идёт тонкая тема
 
 
-3 # BeGoodLife 21.09.2015 16:21
ребята помогите мне надо вывести на екран 4 7 через пробел а я не знаю как
 
 
-1 # Алеша 20.10.2017 17:46
write('4 7'); {Через пробел}

Writeln('4');
write('7'); {Перенести на следующую строку}
 
 
-1 # boomer 25.10.2015 18:25
write('4 7');
 
 
+3 # pascal 12.12.2015 09:55
как вывести сообщение на экран с переменой???
 
 
+1 # Програм 30.09.2021 05:52
program mypascal;
var
name:string;
begin

name:= 'Маша';
writeln('Привет ',name,' !');

end.
 
   ГлавнаяПаскальУроки ПаскальПроцедура Writeln в Pascal